Articles

How to Use Composer for PHP Dependency Management

Composer is a popular PHP dependency manager.

Composer is installed by ServerPilot. However, because ServerPilot makes available multiple versions of PHP, you should invoke the correct Composer command for your app's version of PHP.

Each of the following commands calls Composer using a different PHP version:

Using PHP 5.4:

composer5.4-sp

Using PHP 5.5:

composer5.5-sp

Using PHP 5.6:

composer5.6-sp

Using PHP 7.0:

composer7.0-sp

Using PHP 7.1:

composer7.1-sp

You can also configure the PHP version used when you call just the command composer.

For more information on using Composer, see the Composer getting started guide.


Last updated: August 22, 2016