Articles

serverpilot-installer.py errors

If you run the ServerPilot manual installer on a server not running 64-bit Ubuntu 16.04, you may see one of the following error messages.

Unsupported Distro

Here is the error message you'll see if you attempt to install ServerPilot on any Linux distro other than Ubuntu 16.04:

$ sudo python serverpilot-installer.py
**********************************************************
Sorry, you can't connect this server to ServerPilot.

You'll need to use Ubuntu 16.04.

More info here:

https://serverpilot.io/community/articles/ubuntu-control-panel.html
**********************************************************

For more information on why we target Ubuntu, see the Ubuntu Control Panel page.

Unsupported Architecture

You'll need a 64-bit server to use ServerPilot. 32-bit and i686 architectures are not supported at this time.

$ sudo python serverpilot-installer.py
ServerPilot currently only supports 64-bit systems.
Your system appears to be i686.

Unsupported Kernel

You'll need a server running a Linux kernel version of at least 3.13.

$ sudo python serverpilot-installer.py
ServerPilot supports only Linux kernel versions >= 3.13.
Your system is running 2.6.32-042stab084.17.
This can happen when running a server on OpenVZ with an old host kernel.
You should use a non-OpenVZ server (e.g. KVM or Xen) or switch providers.

Solution

The solution is to create a 64-bit Ubuntu 16.04 server with at least a 3.13 kernel. Check our full server requirements for more information.