‹ Blog

Discontinuing PHP 5.6

September 10, 2019

PHP 5.6 is past end-of-life. Starting this week, ServerPilot will no longer install PHP 5.6 on newly connected servers. PHP 5.6 will continue to work normally on any server where it is already installed. Through the end of this year, you can contact ServerPilot support for assistance installing PHP 5.6 on new servers.

The End of PHP 5

PHP 5.6 is past end-of-life with its final security release having been eight months ago. As PHP 5.6 is the final version in the PHP 5 series, this means the end of PHP 5.

PHP 7 was such a massive improvement over PHP 5 that most developers updated their applications to support PHP 7 within a year or two of PHP 7's initial release. With it now being four years since PHP 7's initial release, we see extremely few apps being created with PHP 5.6.

Discontinuing Early PHP 7 Releases

We will also stop installing PHP 7.0 and 7.1 on new servers as these early PHP 7 releases are past end-of-life. PHP 7.0 and 7.1 will not be removed from servers where they are already installed, so there will be no change to any of your existing apps.

For new servers, you'll now have the option of either PHP 7.2, 7.3, or 7.4.