Articles

How to Install the PHP Stomp Extension

To install a PECL extension for multiple PHP versions, repeat the PECL extension installation for each PHP version.

The PHP Stomp extension allows communication with STOMP-compliant Message Brokers. Learn more about STOMP.

Installing the Stomp Extension on PHP 7.0, 7.1, or 7.2

To install the PHP Stomp extension on PHP 7.X, SSH in to your server as root and run the following commands:

sudo apt-get -y install gcc make autoconf libc-dev pkg-config
sudo apt-get -y install libssl-dev
sudo pecl7.X-sp install stomp

When prompted with the following:

OpenSSL install prefix (no to disable SSL support) [/usr] : 

type yes and press Enter.

The above instruction is not a typo. A bug in this extension's installation script requires you to answer yes here even though this is not a yes/no question.

Once installed, create a configuration file for the extension and restart PHP by running the following commands as root:

sudo bash -c "echo extension=stomp.so > /etc/php7.X-sp/conf.d/stomp.ini"
sudo service php7.X-fpm-sp restart

Installing the Stomp Extension on PHP 5.X

In the examples shown, replace "5.X" with your app's PHP version (for example, "5.4").

To install this extension, run the following commands as your server's root user:

sudo apt-get -y install gcc make autoconf libc-dev pkg-config
sudo apt-get -y install libssl-dev
sudo pecl5.X-sp install stomp-1.0.9

When prompted with the following:

OpenSSL install prefix (no to disable SSL support) [/usr] : 

type yes and press Enter.

The above instruction is not a typo. A bug in this extension's installation script requires you to answer yes here even though this is not a yes/no question.

Once installed, create a configuration file for the extension and restart PHP by running the following commands as root:

sudo bash -c "echo extension=stomp.so > /etc/php5.X-sp/conf.d/stomp.ini"
sudo service php5.X-fpm-sp restart

Last updated: August 31, 2017